Gromacs

Cygwin

    Table of contents
    1. 1. GROMACS 3.3.1-4.5.x
    2. 2. GROMACS 4.0.5

    Version as of 00:12, 24 Aug 2019

    to this version.

    Return to Version archive.

    View current version

    GROMACS 3.3.1-4.5.x

    The procedure below works for single-processor GROMACS on all versions since 3.3.1 on Windows XP running Cygwin versions since at least 2004. Some of the ideas here will be necessary for an multi-processor MPI installation of GROMACS under Cygwin, but no direct guidance is provided. Reading the general GROMACS advice on installation here is strongly recommended.

    The Cygwin package of FFTW3 is in double precision, which is slower to run, so you'll have to build a single-precision version yourself following the instructions below, derived from the GROMACS installation guide. If you've installed the fftw3 package, it'll be best to uninstall it using the Cygwin Setup program (to prevent it downloading and installing other updated packages while you do this, choose "Install from Local Directory" in the Cygwin Setup program).

    1. Get the latest FFTW and GROMACS source packages.
    2. Uninstall previous versions of GROMACS and/or fftw2 and/or fftw3
    3. Unpack the FFTW distribution, cd to that directory and issue
      ./configure --enable-sse --enable-float
      then
      make
      and
      make install
    4. Unpack the GROMACS distribution, cd to that directory, and issue
      ./configure --enable-shared LDFLAGS='-L/usr/local/lib'
      (If you've installed the Cygwin LAPACK package, which is under Math in the Cygwin Setup program, use
      ./configure --enable-shared --with-external-blas --with-external-lapack LDFLAGS='-L/usr/local/lib -llapack -lblas'
      If you've installed another LAPACK or BLAS then adjust LDFLAGS accordingly. If you don't know what LAPACK OR BLAS are then ignore this.) Note that by default GROMACS 4.5 and higher will use threading for parallelism by default, but this is broken on Cygwin for 4.5.5. Accordingly, use --disable-threads with 4.5.5.
    5. Now
      make
      and if all goes well,
      make install
      and
      make links
    6. Edit your login files to source /usr/local/gromacs/bin/GMXRC (or manually add /usr/local/gromacs/man to the MANPATH and check that /usr/local/bin is in the PATH)
    7. If you're not planning to build GROMACS again, or need the disk space
      make clean
      from the installation directory will clean away intermediate and final output from the installation, leaving the installed version intact.

    If you have problems with an old installation of Cygwin, please try re-installing or upgrading Cygwin.

    If you also want double-precision version of GROMACS with double-precision FFTW then you will need to configure FFTW with threads, sse2 and not float, then do "make" and "make install", and then for GROMACS "make distclean" configure as above plus enable double, etc.

    GROMACS 4.0.5

    A procedure for installing GROMACS 4.0.5 has been posted to the gmx-users list.  Please see here for that procedure. Otherwise, follow the instructions below.

    Page last modified 22:34, 8 Jan 2012 by mabraham